Mozilla プラグインチェックページが安全なウェブ体験に貢献

2009年10月4日(日) 14時35分 by level
B ?

これは Mozilla Links 日本語版とのクロスポストです。

原文:Mozilla Plugin Check page to help safer web experience by Percy Cabello -- October 3, 2009 - 9:59 am

プラグインは効果的な更新メカニズムをもっておらず、多くのユーザが数バージョンも古いものを使用しているためにすでにパッチが提供されているセキュリティ欠陥にさらされています。Mozilla はユーザに安全なウェブ体験を提供するために、このプラグインの問題に取り組んでいます。

最近の Firefox 3.5.3 の更新では、Mozilla は更新後に表示されるウェルカムページでインストールしている Flash プラグインのバージョンチェックを開始しました。プラグインが最新でない場合は、最新バージョンを提供するページのリンクが提供されます。

予定通り、Mozilla はこの Flash チェックを他の著名なプラグインに拡大し、ユーザが最新バージョンを使用することにより、既知でかつ修正済みのセキュリティ脆弱性やユーザ体験に影響する他の問題の危険にさらされるリスクの低減を図ろうとしています。

これはまだベータ状態ですが、今すぐ試すことができます。不正な証明書の警告を無視して進むと、インストールされているプラグインがチェックされ診断結果が表示されます。

Firefox plugin check

いくつかのプラグインはそのバージョンを正しく通知しないので Firefox はそれらを常に「潜在的に危険性がある」と表示することがあることに注意してください。Adobe’s Reader プラグインがこれに該当します。私はReader 自身の更新メカニズムを利用して最新バージョンに更新しましたが、まだ警告が表示されます。

Mozilla によると、Windows Media Player プラグインや Real Player プラグインについても同様の問題があるようです。

Mozilla Web Development blog でコメントを残すことができます。

最終更新: 2009年10月17日(土) 14時21分

コメント (2)

1 10/05 12:28 c1
(c1) [2009/10/05 12:28:20] by c1

理解されているのかもしれませんが、誤解をまねきそうなので、
> Firefox が常に 潜在的な危険性 を表示すことがあることに注意してください。

それらを「潜在的に危険(Potentially Vulnerable)」と表示することに注意してください。

本当は危険じゃない場合もあるんだけど、判断できないので危険だと表示しているんだよ、という注意書きなのです。日本語版が見つからなかったのでかぎかっこの中の訳は適当です。

2 10/15 10:05 やすっち。
(c2) [2009/10/15 10:05:22] by やすっち。

>いくつかのプラグインはそのバージョンを正しく通知しない
>Adobe’s Reader プラグイン

プラグインのバージョン自体は正しく通知されています。
先日Reader 9.2がリリースされましたが、プラグインのバージョンが古いままです。
本体が最新でも、プラグインのバージョンが古いままなので、それが通知され、「古い(アップデートが必要)」と判断されています。

トラックバック

トラックバックは検索対象外です。

この記事にリンクしているページ < >

  1. データがありません。